Some services down due to major Microsoft outage

Incident Report for Enreach

Monitoring

Microsoft has implemented fixes and services seem to recover. There could be still issues present, but retrying multiple times will hopefully open services. Enreach will continue to monitor the situation.
Posted Oct 29, 2025 - 22:27 EET

Update

We are continuing to work on a fix for this issue.
Posted Oct 29, 2025 - 19:31 EET

Identified

Some of the Enreach services are not working fully or partly due to major Microsoft outage. Microsoft is working on the solution and we will update the situation once services start coming up.
Posted Oct 29, 2025 - 19:25 EET
This incident affects: Clients (Voice for Browser, Voice for Salesforce, Voice for Dynamics 365, Embedded Voice for Browser), Skype for Business and Teams (Office365 Voice services), and Enreach Cloud (Voice Portal).