Calltraffic problems

Incident Report for Enreach

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 17:25 EEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2025 - 16:33 EEST

Investigating

Dear Customer,

Enreach is investigating possible problems in part of communication services. Multiple customers have reported call-related problems.

We'll update additional information as soon as we know more about the incident.
Posted Jun 02, 2025 - 15:53 EEST
This incident affected: Enreach Cloud (Core services).