Fixed Line Finland call quality problems
Incident Report for Enreach
Resolved
This incident has been resolved.
Posted Jan 14, 2025 - 11:41 EET
Update
We are continuing to monitor for any further issues.
Posted Jan 08, 2025 - 11:08 EET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 08, 2025 - 08:34 EET
Update
Telia is experiencing ongoing network issues which affects Enreach services as well:

https://www.telia.fi/yrityksille/asiakastuki/viat-ja-hairiot/hairiotiedote?id=sabre_800471276&lang=fi
Posted Jan 07, 2025 - 15:16 EET
Update
Root cause has been identified.
Posted Jan 07, 2025 - 15:05 EET
Update
We are continuing to work on a fix for this issue.
Posted Jan 07, 2025 - 11:07 EET
Identified
We are encountering voice delay issues in part of phone calls on our PSTN operator connection. Problem is under investigation.
Posted Jan 07, 2025 - 10:56 EET
Monitoring
We have implemented improvements to D365 calls. The investigation is still on-going if bad quality is present in some calls. Please report any problem calls to Enreach Support.
Posted Dec 10, 2024 - 08:42 EET
Investigating
Dear Customer,

Enreach is investigating problem in Voice for Dynamics 365 phone calls. Some calls experience bad quality and delayed voice.

We'll update additional information as soon as we know more about the incident.
Posted Dec 09, 2024 - 11:54 EET
This incident affected: Fixed Line Networks (Fixed Line Finland).