Password Reset Temporarily Disabled

Incident Report for Enreach

Update

We are continuing to work on a fix for this issue.
Posted Aug 19, 2026 - 10:14 EEST

Identified

Due to a recently identified critical security vulnerability affecting our identity management platform, the password reset functionality has been temporarily disabled as a precautionary measure.

Affected users: Users authenticated through Enreach Identity without Azure federation.

If you need to reset your password while this functionality is unavailable, please contact our support team for assistance.

We apologize for any inconvenience. Password reset functionality will be restored as soon as it is safe to do so.
Posted Aug 19, 2026 - 10:07 EEST
This incident affects: Enreach Voice Cloud (Core services).