Data center infrastructure

Incident Report for Enreach

Resolved

This incident has been resolved.
Posted Jan 18, 2026 - 10:21 EET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 18, 2026 - 00:34 EET

Investigating

Dear Customer,

Enreach is investigating possible problem in part of data center environment.

This incident causes degraded performance in multiple environments, for example mobile calls.

We'll update additional information as soon as we know more about the incident. The incident is most likely related to data center maintenance work.
Posted Jan 17, 2026 - 22:45 EET
This incident affected: Enreach Voice Cloud (Core services, Datacenter Finland).