Call traffic / Telia mobiles
Incident Report for Enreach
Resolved
This incident has been resolved.
Posted Nov 18, 2023 - 21:04 EET
Identified
Dear Customer,

Small portion of Telia mobile subscriptions are failing to make outbound phone calls. We've also noted that some call's might have anonymous a-number, even though user set the a-num to be visible. Problem has been identified and Telia is investigating the incident in their network.

We'll update additional information as soon as we know more about the incident.
Posted Nov 17, 2023 - 12:41 EET
This incident affected: Mobile Networks (Mobile Finland Telia).